Destacada para DockerMientras hoy trabajaba con Docker me dí cuenta de que estaba usando una versión obsoleta, resulta que los repositorios de Ubuntu 16.04 LTS ofrecen la versión 1.10.3, donde al realizar una breve navegación, descubrí que este paquete fue subido el el 21 de abril de 2016, en menos de tres días llevará dos años sin haber sido actualizado.

En Ubuntu la mejor solución para contar con los paquetes más actuales es usar los repositorios de paquetes apt que ofrece Docker, procedimiento que viene muy bien detallado en la documentación oficial, que paso a resumiros a continuación.

Los primero es actualizar la base de datos de paquetes de apt:

$ sudo apt-get update

A continuación hay que instalar los siguientes paquetes para usar los repositorios a través de HTTPS:

$ sudo apt-get install \
apt-transport-https    \
ca-certificates curl   \
software-properties-common

Y añadir la clave GPG oficial de Docker:

$ curl -fsSL https://download.docker.com/linux/ubuntu/gpg | sudo apt-key add -

Ahora podemos añadir el repositorio de Docker:

$ sudo add-apt-repository                                  \
"deb [arch=amd64] https://download.docker.com/linux/ubuntu \
$(lsb_release -cs)                                         \
stable"

Finalmente, actualizamos la base de datos de apt para incluír los nuevos paquetes:

$ sudo apt-get update

Ya tenemos listo apt, así que instalamos docker-ce desde el nuevo repositorio:

$ sudo apt-get install docker-ce

Si queremos usar Docker con un usuario regular, debemos añadirlo al grupo docker (En este caso habrá que reiniciar la sesión en el entorno gráfico):

$ usermod -aG docker usuario

Y ya podemos lanzar un contenedor para probar:

$ docker run -ti --rm debian /bin/bash
root@51d2e37f7d09:/#

 

Últimas versiones de Docker en Ubuntu 16.04 LTS
Etiquetado en:                        

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.